【総合】トピック立てるまでもない質問【Mod制作】

Modやプラグインの制作/開発に関する質問はこちらへどうぞ。
アバター
Xulurun0w0
ID: 5IAAB2BBRF
記事: 44
登録日時: 2019年10月05日(土) 00:41
お住まい: 大阪府
Minecraft ID: Xulurun0w0
連絡する:

Re: 【総合】トピック立てるまでもない質問【Mod制作】

投稿記事 by Xulurun0w0 » 2022年4月26日(火) 02:39

シストラー さんが書きました: 2022年4月23日(土) 12:34 以前似たエラーに遭遇したことがありましたが、その時は環境の何か、多分JDK周りが悪かった気がします。
IntelliJでMDK読み込んだ際に、デフォのJDKの設定がちょっと良くなかった気がします。
一応、下記の環境/手順で実行したら問題なく動作したので、
自分でした手順との差異や、よくわからない、うまくいかなかった部分を教えてください。
ちなみにIntelliJは日本語化済みとして扱っています。

MDK : forge-1.16.5-36.2.20-mdk
JDK : Eclipse Temurin 1.8.0_322
 返信が遅れてすみません。少し忙しかったものですからこちらの方に大きく時間を割けませんでした。
シストラーさんいつもありがとうございます。一応2、3度程手順をしっかり確認しながら作業を行ったのですが、22/04/23に私が投稿した状態と全く変わっていませんでした。エラーログも前回と同様のものです。
 後、シストラーさんが提示されていたJDKなのですが、
「Eclipse FoundationのAdoptium(https://adoptium.net/)からダウンロードできるOpenJDK Temurin hotspot.8u322b06」
こちらで間違いないと思ってはおります。ですが、もしかしたら原因にである可能性もあるため念の為記述しておきます。
こちらからダウンロードできるOpenJDKを利用して動かしておりますので、JDKのバージョン自体は問題はないかと思います。

 そして、追記の部分で言及していたバージョン違いも修正した上でこちらの結果となっております。
特に手順が異なっていた、よくわからない部分などはなかったのですが、シストラーさんが手順6番の際に言及されていた
6. 多分SDKが空になってるはずです。バージョンが1.8のものがあればそれを選択し、無いならSDKの追加->JDKのダウンロード->バージョン1.8、Eclipse Temurinを選択してダウンロードしましょう。
この"Eclipse Temurin"という記述に少し引っかかっています。
 こちらの部分が自分の場合だと"1.8 java version "1.8.0_322""と原文そのままに表示されていたので、もしかしたらJDKのインストールに実は失敗しているのかなとも考えておりますが、どうなのでしょうか...?
0


 実況やろうとしてます。Moddingもやりたいです。4,5年程マイクラやってますがそんなに上手くない悲しみDX

アバター
シストラー
ID: 3N4LQ72B9U
記事: 128
登録日時: 2019年9月13日(金) 19:01
いいね: 1回
いいねされた回数: 29回
連絡する:

Re: 【総合】トピック立てるまでもない質問【Mod制作】

投稿記事 by シストラー » 2022年4月26日(火) 19:43

Xulurun0w0 さんが書きました: 2022年4月26日(火) 02:39 シストラーさんいつもありがとうございます。一応2、3度程手順をしっかり確認しながら作業を行ったのですが、22/04/23に私が投稿した状態と全く変わっていませんでした。エラーログも前回と同様のものです。
ウワーッ!こっちでもバグを再現しました…。
結論から言うと、Forgeのバージョンが古いのが原因のようです。
現在のRecommendバージョンである、Forge-36.2.34であれば問題ありませんでした。
私の投稿でMDKに36.2.20と記述していましたが、これは思いっきりミスです…申し訳ない。
1
1 画像

アバター
Xulurun0w0
ID: 5IAAB2BBRF
記事: 44
登録日時: 2019年10月05日(土) 00:41
お住まい: 大阪府
Minecraft ID: Xulurun0w0
連絡する:

Re: 【総合】トピック立てるまでもない質問【Mod制作】

投稿記事 by Xulurun0w0 » 2022年4月27日(水) 02:38

シストラー さんが書きました: 2022年4月26日(火) 19:43 ウワーッ!こっちでもバグを再現しました…。
結論から言うと、Forgeのバージョンが古いのが原因のようです。
現在のRecommendバージョンである、Forge-36.2.34であれば問題ありませんでした。
私の投稿でMDKに36.2.20と記述していましたが、これは思いっきりミスです…申し訳ない。
 謝るなんてとんでもない...!!質問答えていただいてもらえるだけでありがたいのに、わざわざ手順や再現などを行なっていただいて、感謝してもしきれません(´・ω・`)
Forgeのバージョンを変更して、先日にいただいた手順通りに作業をすると無事に起動してロゴが出る所まで進みました。
本当にありがとうございます!自分の多角的な思考能力の未熟さを改めて痛感しました。もう少し、環境や根底ファイル・Javaのシステム的な癖などを考慮して解決法を探り、何度もこちらにお世話にならない様努力します。
改めてシストラーさん、本当にありとうございました!
0
 実況やろうとしてます。Moddingもやりたいです。4,5年程マイクラやってますがそんなに上手くない悲しみDX

返信する